A more comprehensive fix has been identified and is being tested now. Thank you again for your patience.
Posted May 01, 2025 - 23:56 UTC
Identified
We've made progress in addressing the cause of the performance issues. Performance has improved following our deployed solution. However, further investigation is needed to return the system to baseline performance levels and ensure stability. We will continue to provide updates as we make progress. Thank you for your patience.
Posted May 01, 2025 - 20:42 UTC
Monitoring
We've identified and implemented a solution for the cause of the performance issues. The solution has been successfully deployed. We expect system performance to return to normal levels immediately. We will continue to monitor the situation to ensure stability. Thank you for your patience.
Posted May 01, 2025 - 19:34 UTC
Update
We've identified the cause of the issue. Our team has implemented a solution that is currently being tested. We expect to deliver the solution before the end of day. We'll continue to provide updates as we make progress. Thank you for your patience.
Posted May 01, 2025 - 17:57 UTC
Identified
We've identified the cause of the performance problems. Our team is now working on implementing a solution. We'll continue to provide updates as we make progress. Thank you for your patience.
Posted May 01, 2025 - 16:34 UTC
Update
We have narrowed down the issue causing the performance problems and continue to investigate. We'll post regular updates as we make progress. Thank you for your patience.
Posted May 01, 2025 - 15:16 UTC
Investigating
We have gotten reports and alerts relating to poor performance and failed saving of data on app.higharc.com starting around 9am EST, and our team is investigating.